Procedural Fluid Affector not animating when using RT Refinement/AA settings from the scene

I’ve got an odd issue I can’t get to the bottom of when rendering a procedural mesh that includes a Fluid Affector using Curl Noise on a simple plane to create “bubbles” on the surface that then connect onto another object as it rises up using Smooth Union which as far as I can tell should be a very straightforward scene. I can see the noise animating correctly in the viewport no matter what raytracing/antialiasing settings I use, however if I then go to render this out to video (no matter the format) everything in the scene including the procedural meshing works except for the Fluid Affector. I found that the noise will animate as expected if I override the project settings and set Anti-Aliasing to 1 and doesn’t seem to care about the RT and Simulation Step settings. I thought maybe this was to do with AA stopping the animation of the Curl Noise on the Fluid Affector from ever starting but then can’t understand why it shows fine in the viewport unless that doesn’t render quite the way I think it does. If I export the project to an executable everything works as expected, it will also render with the fluid noise in place if I switch off all raytracing but then the objects are flat grey.

It’s frustrating as it means I’m rendering out at low quality and since I’m using very metallic surfaces the lack of refinement control means it really sticks out. Maybe I just have to really ramp up the RT refinement manually at the point of export instead of finer control from within the nodes? Is there something specific about procedurals and raytracing I’m missing or maybe an AA pass being added somewhere? As far as I can tell I’ve turned it off everywhere it could possibly be but I still just can’t get it to animate the noise on the fluid without having to manually apply the Rendering Passes settings.

Apologies if I’m missing something that is staring me right in the face as is most likely the case!

Hey There :slight_smile:

any chance of a dfx with this issue,

i’ll be happy to take a look for you



1 Like

I eventually got it sorted but can’t remember what it was I did! Thanks so much for the offer of help though, I really appreciate it :slight_smile:

1 Like