Kinect2v skeleton record timeframe

I am trying to record some kinect-stream for a demo with kinect2 (I’ve built from the kinect2 example project)
While let’s say I record 621 frames - but the skeleton data records only 61 frames - so obviously when I play back - it is too quick - and not containing the whole performance. (it would be good to have/to work offline after the performance, the video-kinect stream records seems to be ok).

(By the way - in this file - I am trying to calculate the distance between the two hand - in order to scale some geometries in the scene with the help of the proximity modifier - it works but when I reconnect its output - to another transform node (x,y,z) it sometimes give me #qnan or infinity number - maybe I calculating in a wrong way (I try to clamp or wrap it - where it is possible) (I’ve attached a screenshot and the file)

keplers_dream_demo.dfx (2.1 MB)

Any advise would be appreciated

Hey there,

I cant replicate the QNAN thing, although it does look very peculiar. i guess somehow a bad piece of data is being sent down the chain - is the effect still running okay during the process? do you see it happen in other nodes before or after the combiner? do you have a simplified version of this project only showing that issue, in its simplest and most reliable form?

I can however replicate the Kinect playback speed. At a guess, I don’t think the kinect recording is actually done at 30 fps on the kinect side, so you need to add smoothing and slow the framerate to compensate.

– Ryan

Thanks for your answer!
I suppose this weird QNAN things comes from my chain - I measure the distance from the hip to the waving hands - but I have to negate/invert this result - in order to scale up when it is further away from the center point - I couldn’t managed to do it with the envelop modifier (invert) - so I using the range remap - but it was still not OK - so one more envelop - to turn the numbers into absolute numbers - then it worked - but I think this is the weak-point, if I could just simply negate with one modifier I won’t get any further trouble. I got this error when I connect it for example to a new 3d geo’s transform. Ok, I will try to make it more simple.
Will check the kinect things again - strange, because the point-cloud recording is in sync, just the skeleton is a lot shorter, even if I smooth it down - will check this again (yes, I suppose it is from the kinect-side, not a notch-thingy)

many-many thanks