Unable to enable Kinect2 Skeleton

HI guys,

I am currently testing the Kinect Skeleton Node, but it does not work. Firstly, I have enable my Kinect 2 inside the videoin setting and turned on the skeleton box. However, the skeleton hashed out with red. Therefore, I tried to open the Projection setting to double check and it does not even give me choice for turning on the skeleton in the kinect setting.

Thanks and hope someone can help.

Hey There,

Firstly I would recommend disabling the Kinect V1, as it may be conflicting.

Secondly, have you connected everything up correctly? I’ve attached an example file, let me know if that works.

KinectSkeletonDrivingModel.dfx (285.3 KB)



Hi Ryan! I’ve tried your example file but kinect skeleton doesn’t work, it still has the red lines.
I’ve enabled kinect1 (Only the 1 because I haven’t got the 2). The kinect works correctly, only the skeleton doesn’t work.
How can I do?

Ah ok sorry, now it works! :slight_smile:

Hello, Im using this file attached in the support thread.
I have two MAJOR issues that seem to be common among other users working with the kinect:

1)when exporting the kinect2skeleton layer into a Bin it becomes unsable as it stops detecting the skeleton input (even when it shows the video in capture on the lower right corner)

2)whenever i use another mixamo model with the same rigging structure as the example a bunch of bones axis or positions seem to be reversed/inverted

Any support on this would be extremely helpful!