Imported model not showing correct uvs

So far im trying to get an imported model to show me correct uv’s in notch without any luck.

From my searching, I discovered the mapping node but it seems like it’s not working. please help

thanks for the help …


You need to connect the Mapping nodes output to the Mapping input on the Material node to make it work.

It looks like your UVs are just upside down?
You can use UV scale and UV offset on the material (without a mapping) to flip them; or there’s a checkbox when you import the object from v0.9.18 onwards (coming soon!).

Thanks for the reply everyone, still having trouble with this i notice that jani mentioned making sure my input and outputs were correct, this is what i have so far i do notice your material node is different from mine with more options. please advise on what i am doing wrong .

Ok so i updated to the latest and greatest version, here is a screenshot of what I have still no lucky I feel like I missing one thing not sure what … any ideas