Generate Weightmap Deformer on imported 3D object issue

Hello,
Why doesn’t the Generate Weightmap Deformer work on imported 3D objects?
It seems to work fine with Shape 3D.

I’ve tried it on several different models, and they’re all imported with the “Flatten Scene to Single object” option on.
Shouldn’t there be a Mapping input to it?

Thanks
weightmap_on_imported_model_01.dfx (2.7 MB)

The issue is that the mesh you are using doesnt have any UVs, so the texture doesn’t have any way to be placed on the surface. 3 options from here:

  • go to your favourite modelling toold of choice, and build a uv in there. most have automatic options which are good enough.
  • If you add a mapping node, you can control how the texture is applied to the mesh without a uv map.
  • Use a different mode other than texture.

– Ryan

Indeed, it is the lack of UVs that’s causing this. Thanks for that.

But in terms of the second option, how do I add a Mapping node that affects the way the weightmap is applied?
There is no mapping input to it…
Even if I apply a material with a mapping node on the 3D imported model, it still doesn’t show the weightmap being applied correctly.

After applying mapping node to material you need to set mapping type, scale and coordinates to make it work the way you want.

That was my bad, had forgotten what the inputs were on the node. The other two options still work fine, or you can use procedural falloffs instead for even greater control.

– Ryan

Applying mapping through a material in that way doesn’t work with the Generate Weightmap Deformer.