Import obj with correct texture mapping

I’m trying to import a ply sequence into Notch.
The first step is to be able to import one frame correctly.
I used MeshLab to open the ply and export it to obj (Meshlab correctly map the texture on the point cloud mesh)
When I import the obj and the texture into C4D, the mapping looks ok (for testing purposes)

But when I try to import it into Notch, the texture is not correct.

Do you have any idea how to correctly adjust the mapping? I did not have to do anything special in C4D. In Notch I tried almost all the options without success.
There is also a MTL file next to the obj but Notch doesn’t seem to know what to do with that.

The problem was the Y flipped. I used a -1 scale to the UV and it’s now good.