deleting curves / keys in curve ediitor /Bug?

Hi

After several attempts to delete curves and//or keys in the curve editor I think I perhaps stumbled upon a bug?
Every time I try to delete recorded curves and/or keys made within the midi modifier Notch stops working and i have to restart it.
When I delete the first recorded curve in midi modifier 1 all is ok. When i try to delete the recorded values in another midi modifier notch stops working. Tried it 6 times. So the issue is repeatabel ( at least on my system :slight_smile: )

running latest Notch build 0. 9.18.009 on a macbook pro quad core I7 / 16 gb ram / nvidia 650 / 1gb ram /bootcamp windows 8.1

Hi, Jane.
The latest build is 0.9.18.014: https://www.notch.one/support/forums/topic/maintenance-release-0-9-18-014/. I suggest you give it a shot.

-Andy

thanks Andy, tried the new build.
The Issue occurs also in this build when I " lasso" select the curve of the second midi modifier and try to delete that when selecting “delete” outside the curve in the curve editor.
When I select"delete key" and click on the curve the crash does not occur. So for me it is solved now. Still perghaps something to double check for the next build.
thanks again for you input! Gonna work on your file today again. Progressing slowly. :slight_smile:

Hi Andy, still have issues with deleting curves. Also in the last 014 build.
After a lot of tests and trials and errors I think I I can say with 90 % certainty that the bug occurs when trying to empty out all recorded curves and deleting the last existing curve in the curve editor.
Or is it perhaps that there should at least be one curve left in the editor?

anyway… thought it good to mention this.

cheers

Jane

Hey Jane,

Theres a few other ways to get rid of the whole curve you could try:

-Lasso all keys in curve editor and just hit DEL on your keyboard.
-Find the keyed property in Property Editor and hit Shift-LMB - It will ask if you want to delete selected keyframe (should say curve) - clicking yes will delete the whole curve.

Thanks,
-Jani

Hi Jani, thanks for lettin me know. I m learning every minute so I found the other ways to delete the curves. The lasso method and choosing delete with a right click gives the crash. Perhaps this is not the correct way to do it. I now use other methods which have no issues on my system.
Good to know the one in the property window as well

Building a nice extensive mapping now to my Ohm rgb. testing and progressing. can t wait to try it out. :slight_smile:

Hi, Jane.
Unfortunately I can’t reproduce the crash you are getting based on the attached file on my machine. I’m not sure what it is, but something tells me your midi setup may have something to do with that. Try disabling the midi device you used for recording the track and then start deleting the curves. It will prove useless for sure, but sometimes such ‘voodoo magic’ helps localize the problem.

-Andy

Hi Andy,

Perhaps you are right. I re-adressed all cc s on my controller and made an extensive midi mapping project based on the suggestion member Brett did in another thread on the forum.
I recorded some midi messages…I think a bit too much for my system because i can not delete the curves at all now. Somehow the curves are not really accesible now .
Do you have the same with this attached updated and extended project file? Just to really tackle if this is occuring uniquely on my system?
I think this kind of amount of curves might not yet have been recorded in Notch before ? Or maybe it is time for me to get myself a proper pc laptop like the Razer Blade and my macbook pro with nvidia 650 can not handle it. :slight_smile:

Posted too soon. haha . Deattaching my controller made the curves accesible again. I could delete them all without any problem.
Hope this is the cause. thanks alot for your input. much appreciated.

I’m glad I could help. :slight_smile:
P.S. OMG! I could barely play your last file. Indeed the midi data are too dense. I don’t know if there are ways to lower CC resolution on the fly, but… have you played with the Scale parameter of the Midi Modifier?

Haha yes the scale in the midi modifier was at 100 % on all nodes so that was perhaps too much cc s…
I think I detemined the problem. It was a midi hub that caused my crashes. So far I am running the same project with 26 midi modifier chains and 16 sound modifiers without any hassle on my macbook pro.
Thanks again for pulling me through this. :slight_smile: