Clone to Mesh Alpha Cut off

Hi guys,

I’m currently working with a sphere that’s using a material with an alpha channel, which is being used as the source object of a clone to mesh.

I’m trying to use the ‘colour cut-off’ of the cloner to have the clones spawn in the non-Alpha region, but i can’t seem to make it function properly. Moving the colour cut-off - set to the Alpha channel - only appears to turn the clones on and off (same for luminance).

I’ll fire over the dfx if needed.


Essentially, i only want the grass and the trees (clones) to spawn using the (just about visible) ‘grass spheres’ alpha.


I think the dfx is needed to sus out whats going on here - last i checked this worked as expected, so it could be sset up or it could be a very narrow edge case :slight_smile:

feel free to upload here, or email

– Ryan

1 Like

Thanks Ryan, trees etc take up quite a lot of room so uploaded here:


Use the “Spread over UV Map” option instead, in the mode of the “Clone to Mesh” node, seems to work when I adjust that in your scene and increase the number of UV X & Y clones.

Thanks man!

Yeah i tried that myself, the only problem is they’re distributed evenly and doesn’t look natural. I could use the randomise effector, but that would only work on scale and rotation.

Somehow it only appears to work with the grass model, the trees don’t seem to render when using Spread over UV Map.


It works for me, after increasing the number of tree clones.
Maybe the Alpha cutoff is too high in your scene?


Nice!! Yeah i think you’re right :)!

Thanks man, got this working now, much appreciated!

1 Like