Renders from Adobe CC Plug-In read as having alpha when they shouldn't?

Hi! Brand new user, so apologies for my ignorance. I seem to be having a problem rendering from Adobe with the Notch 1.3.1 plug-in, regarding alpha channels.

The piece I’m rendering doesn’t need an alpha channel, as it has no transparency or anything. When I render it out of After Effects (or export it from Premiere, or transcode it with Adobe Media Encoder), I set the Notch preset to not have an alpha channel, and my composition’s render settings are also alpha-free (RGB not RGP+Alpha, Trillions of colors not Trillions+, Premultiplied not Straight, etc.).

However, the media server operator I sent it to seen an alpha, and I do too when I reimport the Notch render into After Effects… it shows up as Trillions+ and Straight. And that’s even though no part of the media has transparency anywhere (just like the original composition didn’t).

Am I missing something super obvious? It’s possible, I am a newbie!

If it helps, my set up is an Intel Mac on macOS Catalina, the latest Adobe 2021 Creative Cloud apps, and Notch Plug-In for Creative Cloud version 1.3.1.

Thanks! I appreciate the brainpower. :brain: :nerd_face:

I believe I have seen this issue before, and it’s a bit of an odd one so get ready. If you are using disguise, the TL;DR is there is a bug in disguise that means that the flag for not containing alpha is not being propagated to the rest of the system properly sometimes, specifically impacting the Video Transition module. I’d recommend you chat with them and check for any updates incase the issue has already been resolved.
The After Effects bit is an annoying red herring - we noticed the same thing.
Basically when you re-import the video back into AE it flags as having an alpha channel, but if you look at the video file itself with debugging tools it doesn’t actually contain any alpha - AE just adds one on import for some reason.

So if your running into the same issue, then you certainly aren’t missing something obvious :slight_smile: I’m not familiar enough with disguise to give you an easy solution, but if you chat with them I’m sure they can sort you out.

If you don’t have the same issue as above (different media server, or problem persists anyway), could you upload some video files for us to look at?

Cool, thank you so much! That does sound exactly like what’s happening on our team… It’s both in Disguise and in After Effects that we’re seeing the ‘phantom alpha channel’ on import/reimport.

Not sure if you need it therefore, but just in case, here’s a small example of the video file we’re creating, rendered as Notch Optimal and hopefully no alpha channel. :smiley:

notch_noalpha_test.mov

Oops I didn’t mean for that to try to embed as a video… I was trying to send it as a Dropbox link, hehe.

dropbox.com/s/c72j3ghbp3smgou/notch_noalpha_test.mov?dl=0

Hey @ryan.notch I am experiencing the same issue. The image is being rendered with alpha and it is showing transparency in both Disguise and After Effects. It is not just a wrong flag on the video. I have attached a link to the file, a screenshot of the content in after effects showing the transparency at the bottom, and the render settings.

Thanks

JLPA Notch Render With Unexpected Alpha

1 Like