Particles: Point Renderer + Motion Blur = Flickering particles

Hi, Notch Team.
I may be doing something wrong, but cranking up the Motion Blur Amount slider in the Point Renderer results in flickering particles. Please, check this issue.
The test file is attached. Thank you.


Hey Andrei,

The issue is likely to do with changes in frame rate. A small dip in frame rate will cause the particles to think they have slowed down, and spike once the frame rate picks up again.

There are a couple ways to fix this.

  • Enable “Fixed Update Rate” In the Particle Root and specify a frame rate, capping the particle update speed.

  • Open the Timeline Properties window and lower the maximum frame rate for the whole scene below the lowest frame rate drop.



Hi Ryan,

Worked like a charm. Many thanks for the tips! :slight_smile: