Fields 3D Object Emitter Bug?


I think I’ve might come across a bug with the fields. When using the “Densities and Temperatures” in the Field Root, the 3D Object Emitter starts behaving weird, it doesnt seem to be affected by effectors at all. Switching between a Primitive Emitter and the Object Emitter enables the effects, however both cannot be active at the same time for the effects to work.

Deformers seems to work as intended though.

I have attached a simple DFX where I ran into this problem.

Field Bug.dfx (10.4 KB)

Don’t you need to connect the Shape 3D:Sphere to the Field Root as well?
Also changing the 3D Object Emitter & Primitive Emitter Blend Mode, both to Additive seems to fix this.

I did have the sphere connected to the root, but must have disconnected it before saving the file.

The additive setting solved this issue though, can’t believe I missed it. Thanks!

Small clarification - the Shape 3D doesn’t need to be connected to the Field Root specifically, just needs a path to the Scene Root node.

– Ryan