Export movie with audio....no audio!

I have a Scene with a ‘Play Sound’ node…everything works fine in the editor.
When I ‘File → Export VIdeo’ (with Export Audio checked), and write an .mp4…the video has no sound.

Anyone have any idea what I might be doing wrong?

btw: OT, but why is this forum / tool so inactive? I just discovered it and loving it! I would expect a vibrant and active community around such an amazing tool as Notch…where is everyone?

1 Like

I’d be curious to see what export settings you have enabled, as not all codecs support audio export. would also be worth uploading the file so we can dissect it further.

As for where everyone is, we see most of our engagement on the fb user group rather than here - so it depends where you’re looking.

– Ryan

here is my settings: just H.264

re: good to know about Facebook; I left that platform long time ago tho :slight_smile:

here is the file … thanks @ryan.notch !

btw, i put the .exe (and .mp3) in there so you can see what its supposed to look like (more or less, there is a different problem relating to camera on that, but one thing at a time :slight_smile:

This was an interesting one! basically, it looks like there is an issue if you have two play sound nodes in different layers playing at the same time. The good news is the fix is super easy - just disable one of the nodes. The sound will still be picked up by all the modfiers and effectors, it just wont play sound itself and therefore the video audio will export fine.

– Ryan

HA, okay, glad you found that! I’ll delete thanks!

Since you have my file, can you investigate another issue? How does Notch handle cameras when you go to make an .exe ? I ask because I have a camera on one layer (but not on others) that is how I like it in editor (the pink box / butter looking thing) is in middle of screen, but when i export, the camera is zoomed in and looking at just one END of the pink box. Any idea whats happening here?

thanks in advance Ryan!

that worked! Here’s my first Node.One creation! sounds_NEW_capture_08 on Vimeo

1 Like

You need to have a camera in the scene or notch will default to the perspective camera, aka the “0” camera. Add a camera where you need it, and you are sorted.

Otherwise, very nicely done!

– Ryan

Don’t worry. Our main focus for the community is going to be the forum moving forward. Facebook is a closed platform that’s also terrible for discoverability. The open web is where it’s at :slight_smile:

3 Likes