AVI encoding support

How would one create a NotchLC AVI?

Neither Notch nor Adobe Media encoder seem to list NotchLC as an encoding option when selecting AVI export.

Also are there any advantages of AVI for NotchLC over QT?

Hello Isaac,

It does work on my end, and it is just a dropdown option as in Quicktime.
What version of Media Encoder are you using?
Do you have NotchLC for Qiucktime & AVI installed?

I do have the Quicktime & AVI support application installed.

In Media Encoder The only place NotchLC shows up is under the Format dropdown. From that drop down I can only output mov.

Neither the AVI or Quicktime format options list a NotchLC video codec option.

I am fairly confident that the plugin is installed correctly however as NotchLC IS listed under the Quicktime export options in Nuke.

I just can’t find a way to export an AVI in either Adobe Media Encoder or Nuke.

It’s not a need for me right now but it’s listed as an option and quicktime encoding can sometimes be problematic so having a different muxing option is nice.

Hey Isaac,

That sounds weird as it should just show up like any codec you might install. Here it is in media encoder.

As for difference between AVI vs MOV, its more about what the rest of your pipeline and what it can take.


Interesting. I don’t have those options.

I’ve re installed and rebooted a few times and not be able to get these settings.

Like I said not an issue at the moment but it’s pretty strange.

It could potentially be something specific in your windows or setup. If you have another computer you could try if it works any better on that to try to isolate the issue?

Are all other codecs working ok ?


So it’s actually become important for me to get the AVI support (see my other post about scriptable pipeline)

I’ve tried to install on three different machines and I’ve not been able to get any of them to work.

All using Adobe Media Encoder 2019 (what ever the latest is of this writing)

  1. Windows 10 Pro for Workstations build 17134 with Visual studio installed.
  2. Windows 10 Enterprise build 17763
  3. Windows 10 Pro (don’t recall the build but probably latest) also has VS installed

On the workstation and enterprise build I get the following error during install.

I point it at windows\system32 which has the file in question and it works but that seems concerning.

Any additional suggestions?

So I was digging into the installer a little bit and it looks like there is an error where it is skipping adding some registry keys.

notably it didn’t add

HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\drivers.desc",NotchLCcodec.dll,,"NotchLC video codec" HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32","VIDC.NLC1",,"NotchLCcodec.dll"

I added these entries and the NotchLC option showed up in the AVI codec options. I did an encode and it seemed to work. It seems like something might be amiss in the installer code.

Nice one! This will definitely help the devs to track this down.

Great detective work!


hey any updates to this thread? Still getting this error when trying to install on my end as well.

Hi there,

I’ve logged this as an internal issue now and it will be looked into. Thanks for bringing it to our attention. For now, are you able to work around this by using another container than AVI for your NotchLC encodes?

I have had the same problem with my recent windows 11 computer with MPEG Streamclip and also with disguise D3.
Could someone tell me if the problem has been solved or if not how to attach the solution to the registry: Isaac Gierard.
Thank you so much

Windows 11 is currently not on our official supported OS list, seeing at it was jut very recently released.

I format, I install windows 10 and it gives me this error …

Could you send this issue into support so we can look at it more closely? Just to avoid clogging up this post.

– Ryan