4090 (poor) performance

I’ve tried running the same project on two machines - one with a 3090ti and the other with a 4090. The 3090ti is running the project about 3-4fps faster than the 4090, which seems strange.

Is Notch just not optimised for 40-series cards yet? I’m running Notch 0.9.23.248 on Windows 10.

Looking further into this the issue seems to be that Notch is triggering something called PerfCap - VRel (stands for PerformanceCap due to Voltage Reliability). If I run the GPU-Z tool and watch the sensors as I run the Notch timeline – as soon as I hit the spacebar in Notch the PerfCap is triggered and the GPU usage is capped at 60%. I’ve tried switching to the Game Ready drivers (instead of Studio Drivers) and that gets the usage up to between 70-75% – but still far short of the capability of the 4090.
I’ve tried running the Notchmark and I can consistently beat the 4090 score that Notch have advertised themselves on the site. But that doesn’t seem to translate into real-world performance. When I run a 3rd party benchmarking tool (eg. Furmark or Uningine Superposition) it easily takes the computer to 95-98% GPU utilisation, and never triggers the PerfCap.
Am I missing a setting in Notch that will mitigate this issue? I’ve already tried changing the TDR setting in the registry to 60 seconds as per the recommendations.
My system specs: Win10 64-bit, i9 10940x 14core, 64gb RAM, Gigabyte X299X Designare MB, Gigabyte 4090 Gaming OC

1 Like

I second this! Having exactly the same performance issues with my 4090

1 Like

Do you mind sharing your rough hardware spec? I’ve seen info from non-Notch users that have the Vrel issue, and they solved it by upgrading to 13th gen procs eg. 13900K + Z790 MB and the issue went away. The theory is that it’s a CPU bottleneck.
If you’re on similar gen CPU to mine it might be a clue.

Sure

CPU - AMD Ryzen 5 7600X 4.7 GHz 38MB
GPU - ASUS GeForce RTX 4090 24GB TUF Gaming
Motherboard - ASUS ROG Strix B650E-I Gaming WIFI
RAM - Corsair 32GB (2x16GB) DDR5 5200MHz CL40 Vengeance

What size power supply are you using?

Perf Cap is resource limitation…

My guess is you need a bigger power supply. In order to feed the beast, it needs to be ATX 3.0.

https://www.msi.com/Power-Supply/MEG-Ai1300P-PCIE5

I’m using a 1300w ATX3.0 with a 16-pin direct feed to the card. It can easily push past 450w with benchmarks like Furmark. But Notch struggles to take it to 150w.

I’m running the same… How bout RAM… DDR4 or 5? What’s the rest of the specs?

Does your card have a dual bios switch? (quiet/performance modes)
Does your PSU have a ECO switch?

RAM is 3200mhz DDR4
Card has switch for OC or Silent - it’s set to OC. Not sure on the PSU - it’s an MSI meg ai1300p

my specs are almost same… 128gb DDR4, 19-12900

I would double check for anything that would limit the voltage… Maybe start here.
Nvidia control panel > manage 3d settings > power management mode > prefer maximum performance.

Yeah I’m set to Ulimate mode in Windows power profiles. Every CPU setting I can find is set to 100%. Already have all those Maximum Performance settings enabled in Nvidia control panel.

All the cables seated properly? Are you getting sufficient power to the PSU from your outlet? Ironically, this is usually the last thing I think of when troubleshooting… yet It’s been the culprit in quite a few elusive situations. That’s the bottom of the barrel from me. Hope you get it figured out.

the PSU has only just been installed by a professional build shop. I’m feeding the PSU from a UPS so should be all good.
I can easily get over 450w to the GPU using apps other than Notch so seems like that’s not the issue

I would try bypassing to a dedicated outlet just to see…

Just tried that - no difference unfortunately. Still hits VRel. Notch got back to me and didn’t really offer any solutions, but their explanation seems to indicate that CPU bottleneck is the issue.
Trying not to get frustrated…
Thanks for the help so far though - much appreciated.

Maybe you need to turn it down a notch. ; )

https://www.reddit.com/r/nvidia/comments/11dn5ks/rtx_4090_undervolt_power_limit_mystery/

Finally figured out how to do that (I’m a Mac guy – this is all uncharted territory for me). Undervolting means I can avoid hitting VRel when the Notch timeline is running. But I get no gain in FPS, and GPU utilisation is still sitting at around 60%.

I’m running with a similar set-up, 13900k, 64gb ram, 4090 and can utilize all 100%.
Im assuming youre on the latest drivers etc…?