Volumetric lighting & Render to texture node

Hi Guys, having an issue with Volumetric lighting and the Render to Texture node. As you can see image, the volumetric lighting is working in the Render to texture preview, but when its used on an Image 2D, you don’t see the beams of light. any solutions as to getting it working?



Can you share your DFX file, it’s a little hard to tell from the image alone, but it smells like a blend mode issue somewhere.

Hi Bent

There was alpha in the render to texture node which wasn’t allowing me to see the beams. I fixed it by sticking a huge plane in the distance to remove the alpha.

Is there a way to add some blend controls to the render to texture like there is on the root node?


I’m not sure about blend modes, as the render to texture just generates an image, the Image 2d handles how that image blends with a scene. Rather than a plane, I’d recommend using the channel boolean, and setting the Alpha channel to 1. maybe a “Render Alpha” toggle is worth looking into though.

In the next release, Volumetrics will have alpha too, so you might not even need these workarounds. :slight_smile: