Trying to get object to cast shadows

I’m just getting started with Notch so bear with my noobness please!
I’m trying to get a spot light to cast shadows. Here you can see the spot going right through the sphere. I have the cast shadows checkbook checked for both the sphere and the rings. The (spot)light has a Cast Shadows checkbox which seems to be greyed out although I can check/uncheck it (still does not help). I saw something about shadow maps in the manual but not sure where to start there… :no_mouth:


To get the shadows (and many other features) working you need to turn on Deferred Rendering on the Root node. If you are doing lighting you should also try Linear-Space Lighting and HDR (on the Root).