Shadow catcher material problem


I can’t seem to get the shadow catcher material to work. I get the shadows working on a plane with a base material, but as soon as I link a Shadow Catcher Material, the plane goes black. I can see the shadows are there if I change the shadow colour.

it works fine with the template that is included with Notch and I have gone through all of the settings and think they are the same! What am missing here? Something simple?!


The shadow catcher is designed to pick up the shadows and render them in the alpha channel, so that in a AR / Virtual Production context, you could have a generated object cast shadows onto a real floor - so that’s why the material goes black, and the colour shows where the shadow is. You’ll probably need to set the scene composite blend mode to blend with alpha channel too.

What are you looking to do? It might be your barking up the wrong tree with the shadow catcher node.



Hi Ryan,

Thanks for the response!

I assumed this material would emulate the shadow catcher materials you find in Vray or Corona, so you only render the shadows on a floor, rather than the floor itself?

I have a basic scene with a nice background ramp with fog scattering. There is a floating jellyfish and I’d like to see shadows on a floor plane beneath it, whilst retaining the background colours.



Just to be clear here - the supplied template that comes with Notch does exactly what I want it to do; you only see the shadows on the plane and can see the backplate behind. It’s just that I am unable to recreate that from scratch fopr my scene, although I’m matching all the settings (I think)

Ah I see, well without seeing the scene I couldn’t say for sure what is going on then. Mind uploading it here, or sending it to ?

Cheers for your help Ryan, makes sense now!


1 Like