Alpha Material Issues

I’m having issues with the alpha channels when making a material. I have a PNG-file with en empty background that I want to use, but I cant make sense of how to go about this.

I’ve looked at the manual but it doesnt help me that much, there’s also another post about alpha channels on an image plane, wich suggests to set alpha mode to blend and use add as blend mode, but this method leaves me without the material properties I need for the project.

Here’s the image previewed as is in Notch. As you see the alpha channel is working.

Here’s the same image used in a material node on the colour texture and alpha channels, with the alpha set to coverage. Material node is used on a shape 3D with a sky light node in the scene.

Here’s the same setup but with alpha mode set to blended and blend mode to add. It just vanishes, I made the background red here so that you would see the black letters, if they were visible.

What am I missing?

Without a project file its difficult to give exact steps, but here’s my thoughts from where you’ve gotten so far.

  • The material properties don’t work because you are likely using alpha blended, a material type which isn’t compatible with advanced 3d lighting, like the sky light.
  • The image is presumably black everywhere, with only the alpha making some text visible. Additive blend mode adds the values from one image to whatever is behind it, like a layer in photoshop but in 3d, so you essentially adding black to a black background.
  • I think for what you’re looking for alpha to coverage would be the correct option. which is also available on the image plane. I think its inverted in your image though, so i think there is more going on in your scene i cant see from the screen shots above alone.

– Ryan