Lighthouse - Light obscuration/blocking

Hi guys… As you can see from the image, the columns aren’t blocking the light beam. It is passing through the opaque columns which looks wrong. What is the best way to achieve this? Thanks in advance :slight_smile:

2 easy solutions:

  1. Turn off the scattering via keyframing or modifiers whenever the light moves towards one of the corner walls. There’s hundreds of ways you could do this depending on your setup, but it would be the easiest to implement.
  2. I think you are using the light scattering beam for the light source, which is designed to be super cheap and super fast, but has limitations to what it can do. A more realistic approach would be to use volumetric lighting as well as a normal light with shadows enabled. That’ll be more realistic, but more impactful on performance.

– Ryan

Will definitely check this out. Keyframing would be the fastest I think but any speed changes might affect the keyframes. Will try to figure it out with some modifiers/expression. Thanks a ton Ryan :slight_smile: