Kinect Azure glitches like crazy

Hi everyone, i am having a weird problem with the azure kinect. When i run the Kinect sdk the video feed is stable. I open the Kinect in notch and the video feed glitches as if it has the digital block glitch node applied. But instead of colors it looks like it is flashing the frame but with an offset 50% on X - so if i have an empty room with a chair in the middle i get these glitchy frames where i get two halves of the chair on each side of my screen. The kinect firmware is 1.4.0 which was giving me the same defect on the previous version of notch ( the latest one before the nvidia AI tracking update). I am currently using the latest version of notch. I have not yet updated the Azure, will do that today. Is there something else i can also try or i am doing wrong that might be causing this glitch?

I remember reading in the manual that you may want to try switching to a different usb port if experiencing glitching. Might be worth a shot.

Yes, I remember reading that too some time ago, tried all ports but to no avail. Thank you for the suggestion:)

I dont think i’ve ever heard of this issue before. as @Dalton_Sessumes says, 99% of the time this is a bad USB port, or a bad cable, or both. it could be a firmware issue, so i’d start by double checking that and making sure thats up to the latest. similarly, it could be a bad driver install, so i’d re-install k4a drivers on both your PC and the device itself. if both of those dont help, this sounds like a very unique case - send a message into support and we can help you out there.

– Ryan

It might help to post a screen recording of the issues you’re experiencing.