Unable to write/open/read (Demolition FX popup error)

Hi everyone, nice to talk to you.

I have just acquired a new machine to ensure my future real-time productions. The computer being freshly set up and configured, I installed Notch first. I have a problem that I don’t have with my old machine, I can’t open any DFX file, nor save any current project.

Repro steps:
I record my screen to show you how this happen, when I want to load, or save.
See Youtube video here

Expected result:
Here, I wanted to load sample/template or other DFX files, and also want to save my projects.

Actual result:
Unfortunately, I can’t solve the problem. I tried to reinstall the software, tried to run it as an administrator, check that the executable is indeed in write and read mode. I quickly go through the possibilities since the machine is new. I provide you the log created in connection with my manipulations seen in the video above.

notch_log__2021-01-29__10-15-21.txt (52.7 KB)

Specs :
Notch Builder // PRO
AMD Ryzen 9 5950X 16-Core
GeForce RTX 3090 (Driver up to date 461.09)

Thank you for reading me, I’m sure you’ll quickly find the why of the how!

I’ve just solved the problem (although it’s been dragging on for 2 days).

The problem is related to the name of the windows session. I noticed this problem in the preferences of the software, you can see that the accent on my first name is not taken in all folders directory.


So I created a new session without accents, and when I open Notch, I don’t have the problems I mention in this topic anymore, but in addition I gained the thumbnail previews since this time the files are correctly read.

Maybe there is an update to do to avoid this kind of problems in the future?
That said, the problem is solved!

Thanks anyway :stuck_out_tongue:

1 Like

I was about to say - checking the logs that looks like the issue :slight_smile: Unicode characters in the file directories break the file paths, its a known issue we will be looking to address in future. For now, you will need to do as you say, and use an account without those characters.

– Ryan

1 Like