OSC Help

I am trying to send over from NI Mate the position data of the Head Via Isadora. I have it going as far as isadora at the moment but can’t seem to get it to show in notch or how to link it to a parameter to control.

Any help would be greatly appreciated.

Ryan Gregg

So you are able to send the OSC from Ni Mate to Isadora but it wont receive in Notch? Make sure that you restart Notch if you just set the port because sometimes it doesn’t update it immediately. You can check the current port its listening for by going to view>connection monitor. Also make sure that no other apps are picking up the OSC signal.

Sorry I’ve just been told that actually we are trying to send the position data from Ni Mate to Notch via spout via OSC however I’m not 100% how to then see if it working in notch apart form looking at the connection monitor which shows i have a connection and receiving packets.

If it is receiving packets, you should be able to read the values with the OSC modifier if you are listening for the correct address. If that doesn’t work I would check the OSC value with another program like OSC Data Monitor, to make sure Ni Mate sending it out correctly.

atm I have the address in Notch set to /Head/X. Also, I how should NI Mate be sending out the data ?.


Do I need a certain version of spout at all for Notch ?

Make sure its set to the same port Notch is listening on. If the Notch connection monitor says its listening on the correct port and the number of received bytes is increasing, then Notch is properly receiving the data. Also make sure the OSC Modifier is actually connected to something or else you won’t be able to see the data coming in.

What would you suggest connecting it to ? literally anything

No, Spout works fine with any application. If you are Spouting in, you just need to go to Devices> Video In and enable Spout Receiver. Then the Video In node will allow you to access the stream.

Yup, just the position X input on a null would work fine.

this just dosen’t seem to want to work in NI Mate in the skeleton tracking I have the head address set as /Head, then in Notch I do the same on the OSC modifier with a OSC output

I assume the current value should be changing if it’s worked ?

From that NI Mate screenshot it looks like it is sending out all three position values at once from the same address, so instead, try putting in /Head into the OSC modifier and then you can access X, Y or Z values by changing the OSC value index.

Also connect the modifier to a shape 3d or null that is connected to the root node. Sometimes the OSC output modifier doesn’t show you changing values unless its actually hooked into something.

Also make sure Notch is playing.

Okay great thanks will try that tommorow and will let you now if it works.

Ryan Gregg

this isn’t working I’m now very confused completely

Ryan Gregg