Auto Save - Freezing Scene

While the Auto Save function is really great, but it freezes rendering for several seconds (even with a SSD). Would be great if there a way save everything in the background without interrupting Notch…

What kind of scene is this? Do you have lots of large files imported and embedded with the scene? You may be able to speed up the saving time if you set some of these files to not embeded in the dfx.



Ok, so how to not embed external files? Normally in other 2D and 3D software imported assets are not part of the scene file and Notch does not offer an option when importing 3d objects to link/embed.

What influence has the setting “Project Compression Enabled”?

Thanks Ryan!

We allow embedded resources because it makes file sharing significantly easier, but certain assets default to embedded and others don’t depending on their typical file sizes.

In the resources window, you can right click and select the option “Do Not Embed Resource” here. When selected, the resource will appear in orange in the resource window and not be saved with the project file.

“Project Compression Enabled” compresses the DFX on saves, but not autosaves, so that wouldn’t apply here. You can disable it if you want to improve save times (sometimes by a lot), but your DFX can get a lot larger without compression.



1 Like